Strony

niedziela, 8 listopada 2009

PLD: upgrade to lighttpd-1.4.24-4.i686 in some cases fails

Today, upgrading from lighttpd-1.4.23-1.i686 to lighttpd-1.4.24-4.i686 make lighttpd unable to start, in my case I have definition of certificate inside HOST definition, with doesn't metter :) (but it worked). The TLS_SERVER_NAME_INDICATION patch has been added to lighttpd. Now you should have global definition of pem file, if you don't you can see sth like this:

2009-11-08 11:15:49: (network.c.501) SSL: can't use ssl.pemfile with $HTTP["host"], openssl version does not support TLS extensions

0 komentarze: