Strony

wtorek, 11 listopada 2008

transmission-1.40 at centos 5 libcurl problem

When I tried to update my transmission (1.34) bittorent client to newest version 1.40 at centos 5 I got a configure error:
Requested 'libcurl >= 7.16.3' but version of libcurl is 7.15.5

and it is true... libcurl in centos 5 is now 7.15.5 and probably will not be updated in a short time. As a solution, I tried to rebuild a fedora 8 src package.

What I need was: curl-7.16.4-8.fc8.src.rpm and rpmbuild in my centos system. You will probably need nss-devel and nspr-devel so install it before running rpmbuild.  Let's rock:
rpmbuild --rebuild --define 'dist .el5' curl-7.16.4-8.fc8.src.rpm

after some time you should get files:
-rw-r--r-- 1 root root 675076 Nov 11 10:19 curl-7.16.4-8.el5.i386.rpm
-rw-r--r-- 1 root root 206491 Nov 11 10:19 curl-devel-7.16.4-8.el5.i386.rpm

of course, you can download them from my repo (click at them). Now you can easly install both:
# rpm -Uvh /usr/src/redhat/RPMS/i386/curl-*
Preparing...                ########################################### [100%]
1:curl                   ########################################### [ 50%]
2:curl-devel             ########################################### [100%]



7 komentarze:

h pisze...

error: Failed dependencies:
libcurl.so.3 is needed by (installed) gnupg-1.4.5-13.i386
libcurl.so.3 is needed by (installed) curl-devel-7.15.5-2.el5.i386
curl = 7.15.5-2.el5 is needed by (installed) curl-devel-7.15.5-2.el5.i38

Marek pisze...

Do you have tramission srpm that builds on el5 without problem?

Marcin Rybak pisze...

I did not use transmission srpm, I installed it from sources

Vladi pisze...

Hello Marti!

I am trying to find a solution to install transmission 1.42 without breaking CentOS's dependency system.
Here what I doing:

http://forum.transmissionbt.com/viewtopic.php?f=2&t=6768&p=33043&hilit=centos#p33043

No solution yet. :(
Please let me now, if you have some idea.

Marcin Rybak pisze...

Helo Vladi - I've made some tip at transmissionbt forum,
regards

Vladi pisze...

Thanks the help Marty, unfortunately still no success. :(

marti pisze...

I've updated links, and also added a new post connected with new transmission 1.73, and problem with intltool.